Basic requirements

    Follow

    Our minimum requirements for AutoMaths are:

    - Broadband Internet access 

    One of the following browsers:

    Firefox: (latest browser version)
    Google Chrome: (latest browser version)
    Internet Explorer: v11
    Safari: (latest version of MacOS)
    Safari (iPad Tablet): IOS11 +

    Microsoft Edge is not fully supported at this time and the content is best viewed on the supported browsers, such as Chrome or Firefox.

    Please note: As Chrome no longer supports flash files, we recommend Firefox as the preferred browser. Read more

    If you have any questions or concerns about the compatibility of your setup with AutoMaths, please submit a support ticket with our support team, and we will do our best to help. 

    Was this article helpful?
    0 out of 0 found this helpful

    Comments

    Get Additional Help

    Ask for help from our Digital Support team by submitting a ticket request.